Cloudability logo
Registration is Now Open for CloudyCon 2019
Company News

Cloudability & POODLE

By Mat Ellis on October 15, 2014

Yesterday, Google researchers found another serious security vulnerability relating to SSL. It’s called POODLE, and you can read more about it here and here. (For technical folks the CVE is here).

Over the next few weeks you will see updates to your browsers that remove support for SSL 3.0 in light of this discovery—but we take your security very seriously, and didn’t want to wait that long. So today, we have disabled support for SSL 3.0. This means you will be protected from POODLE when using Cloudability.

If you have any questions, please feel free to reach out to us at support.cloudability.com.

Being in the know feels great